Issues connecting AllPixelMini


I’m having issues hooking up AllPixelMini. The board is not recognized as a USB device, or any device for that matter.

My setup is Raspberry Pi 4 Model B -> USB cable -> AllPixelMini. When I plug in the AllPixelMini board (and no LEDs), the light shows stable green. If I connect some LEDs to the board, the green light keeps flashing and all LED’s are flashing rapidly with it. Even tried with two different 5V wall adapters for the power to the pi.

I also tried connecting the AllPixelMini to my MacBook Pro, but same issue.

Nothing is even showing up in the system logs when I connect the board (by checking the dmesg command)

I actually bought three AllPixelMini’s (in Oct 2020), and I have the same issue with all of them.

Not sure where to go from here. Thanks for any advice.

Have you tried a different USB cable?
That is mainly concerning the computer seeing the APM without any LEDs attached. Some USB cables are power only and don’t work for data. So if you haven’t tried another one, try that.

Also, you should never try to power LEDs through USB on a Raspberry Pi. Always use a secondary power supply on the APM itself. The flashing green LED on the APM tells me it’s not getting enough power.

But likely it’s a bad USB cable.

Thanks for the quick reply!

I think you’re right, the flashing issue was probably because I connected a strip with 60 LED’s to the board. Just tried a smaller strip with only 2 LED’s, and the APM light is stable green. Both LED’s are bright white when the USB is connected.

Yeah, I tried two different USB cables, which by the looks of it have all the pins for power + data in the micro-USB end. But both cables are actually pretty thin so maybe there’s no data line in there and only VDC±. But since the APM is not showing up on either the Pi or my MacBook, perhaps I should go and buy another USB cable just to be sure.

I’ll keep you posted!

Yeah - the connectors will always have all the pins. But the cable won’t. And if it’s thin, it’s prob data only.

You were right - it was the USB cable. It seems I tried with 2 different power-only cables. Bought a new one today, specifically with data+power, and the APM is now recognized as a USB device!

Excellent! Glad it’s working now :slight_smile:

1 Like