Error when setting up Neopixel strip with PiPixel


I have a neopixel strip (2812B) connected to my PiPixel and I have installed Bibliopixel on my Rasp Pi 3. I’m trying to run the test command:

bibliopixel run

in the command line, yet when I run it I keep getting an error. The error that displays is:

ERROR - project_runner - 1 project failed

ERROR - project_runner - No such file or directory:

Traceback (most recent call last):
File “/home/pi/.local/bin/bibliopixel”, line 16, in
File “/home/pi/.local/lib/python3.7/site-packages/bibliopixel/main/”, line 31, in main
File “/home/pi/.local/lib/python3.7/site-packages/bibliopixel/commands/”, line 12, in run
File “/home/pi/.local/lib/python3.7/site-packages/bibliopixel/project/”, line 27, in run
projects = _get_projects(args)
File “/home/pi/.local/lib/python3.7/site-packages/bibliopixel/project/”, line 199, in _get_projects
raise ValueError(‘Run aborted’)
ValueError: Run aborted

not sure if this means I have installed Bibliopixel incorrectly or not, but I would appreciate any input that gets my strip up and running.

That’s odd… What happens if you download that file and run it locally?

I was able to self diagnose the problem when I ran it from a local file. I directed me that PiWS281X Requires the rpi_ws281x C extension. I installed the extension, and the program ran as expected. We have light!

Awesome :slight_smile: And I just realized why it wasn’t working… derp :stuck_out_tongue:
You were using the normal github URL but that serves up a web page not a json file… if you click on the “Raw” button at the top of the file, you will get this URL:
Which should worry.
Sorry about that… I always forget to check the URL format from github.
Was that URL in our docs somewhere? If so, where? I should fix that!

You’ve been a great help! I don’t know if you recall my earlier post, but I was able to take your advice and solder up a Pihat that uses a MOSFET to control my analog LED strips too!

The documentation that included the URL that I used is on this page:
It’s under the area where you explain how to test a WS2812 strip.

Awesome. Thanks… There’s a lot of docs all over the place (especially with BiblioPixel stuff in docs for the hardware) so it’s a little hard to keep track of.
Weird thing is that I just looked and realize we have code in there to specifically be OK with the bad github URLs and convert them into the right format… which doesn’t work now. Maybe they changed their format? I’ll see what I can figure out.