AllPixelMini issue with set-up


I am having some difficulty installing an LED strip using the Allpixel mini. I have worked with it in the past without issue…

Rasp Pi 3B+ Running Buster
When I run the test Python script for LED Strip WS2812B, Nothing lights up… and I get this error message:

WARNING - deprecated - util.setLogLevel
INFO - devices - Using COM Port: /dev/ttyACM0, Device ID: 0, Device Ver: 0
WARNING - deprecated -
DEBUG - animation_threading - Animation starts on main thread

Any help would be appreciated.



Can you link to or provide the test script you are actually using? There’s a few out there.

Hello Adam,

This is the script I am using:

import bibliopixel
# causes frame timing information to be output

# Load driver for the AllPixel
from bibliopixel.drivers.serial import *
# set number of pixels & LED type here
driver = Serial(num = 10, ledtype = LEDTYPE.WS2812)

# load the LEDStrip class
from bibliopixel.layout import *
led = Strip(driver)

# load channel test animation
from bibliopixel.animation import StripChannelTest
anim = StripChannelTest(led)

    # run the animation
except KeyboardInterrupt:
    # Ctrl+C will exit the animation and turn the LEDs offs

Any help would be great!

Thank you,

Can you change this line:




That will output a message for every frame it tries to write to the AllPixel.
I’m assuming that it will work and you will see a bunch of frame messages as there’s nothing in that test script that shouldn’t be working.
If that’s the case then there’s likely a problem with your strip or how you connected it. If you get all those frame debug messages, please a couple pics of your setup showing as much detail of the wiring as possible.

Indeed it works. I spent a lot of time testing… exact other strips work with the same wiring/set-up. I have a feeling it’s a bad strip.

1 Like