Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
LED's not working
Hello All,

I hooked up my led's to my allpixel and ran the allpixelstriptest and nothing happened. I have checked my solder points and have both of the resistors, the diode, and the cap on the board. I run the python and it shows me the debug output and when I hit the button on the allpixel python stops. These are working strips as I have had them hooked up to my pi via gpio. I have tried on a windows 10 machine and a raspberry pi. Any suggestions?
Could you take a close up picture of the AllPixel, preferably straight on and from a couple of slight angles? It certainly sounds like a connection issue and that will help us diagnose if there's a problem with one of the components.


1) What type of LEDs are you using? Could you take a picture of the strip connected as well? Maybe you have your clock/data lines switched.
2) How many LEDs are you using total?
3) Are you powering them from USB or from the barrel jack?
4) Are you seeing ANYTHING flicker on the LEDs? If yes, it's probably a data connection issue. If no, it's power.

we'll get it figured out. no worries Smile Just need the info above.

Please forgive my lapse, while I was taking the pictures I noticed that I had wound the strip on the spool backwards. So I was connecting the Allpixel to the DOUT of the strip rather than the DIN. Low and behold I flipped it around and it works great.

Smile No worries! Glad it's working!

Forum Jump:

Users browsing this thread: 1 Guest(s)