Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installation failed
#1
Hallo,

I tried to update BiblioPixel via
Code:
pip install BiblioPixel --upgrade
I got the following error message:
Code:
       import bibliopixel
     File "C:\Users\...\AppData\Local\Temp\pip-build-fo8lo5r2\BiblioPixel\
bibliopixel\__init__.py", line 1, in <module>
       from led import *
   ImportError: No module named 'led'

   ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in C:\Users\...
\AppData\Local\Temp\pip-build-fo8lo5r2\BiblioPixel

After that I updated pip and setuptools. Than I become the same error by updating BiblioPixel.
Than, I tried to uninstall and install BiblioPixel, I getting the same error.

Please help me.

Thanks
fluesternBlock
#2
Can you run "pip freeze" and send me the output?
I just tried this myself and had no issues. Was that error during the BiblioPixel upgrade or after trying to run a script?
How did you uninstall BP? "pip uninstall BiblioPixel" should do it.
What operating system and version of Python are you using?
Sorry I just have more questions, but without being able to reproduce it myself it's hard to diagnose without more information.
#3
I am not at home. I send you the output of pip freeze later.
I uninstalled it with "pip uninstall BiblioPixel" and I tried to install it with "pip install BiblioPixel".
I develop my animations on my windows computer with OS Win8.1. I updated python yesterday. My python must be up to date. But this I can write later, too.

I use your library for a long time and I haven't any problems like this. I think this is a problem on my computer. But I know, that you are the best person who can help me. I have to try to update on my pi. But I think, on my pi it will work.

The 2nd thing i tried is: I downloaded the zip-file from GitHub. After that i tried to install it with "python setup.py install". Same failure as described.

Sorry for my english. I am from Germany.
Your library is a great work from you. I am a developer, too. I haven't enough time besides my work. I build a led matrix. I developed three animations. Now I saw you included new animations and I want to integrate it into my matrix.

Thanks for your help!
#4
One thought... did you update to Python 3 by chance? Only 2.7 is supported.
#5
Hi
Thanks!
It work.
I forgot these.
#6
Ha... nice Smile Sorry about that.
Would love to support both 2 and 3, but most still use 2 these days.
Glad it's working!
#7
I was also facing the same problem. Cool


Forum Jump:


Users browsing this thread: 1 Guest(s)