Welcome, Guest
You have to register before you can post on our site.

Username/Email:
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 507
» Latest member: caitlin.sherwin
» Forum threads: 88
» Forum posts: 404

Full Statistics

Online Users
There are currently 8 online users.
» 0 Member(s) | 8 Guest(s)

Latest Threads
New tdsp color list Pytho...
Forum: BiblioPixel Development
Last Post: roykerman222
03-14-2017, 05:13 AM
» Replies: 1
» Views: 1,323
Art-Net Support
Forum: AllPixel Support
Last Post: dfive
03-04-2017, 03:09 PM
» Replies: 3
» Views: 758
Animated Porch Lights
Forum: Show-And-Tell
Last Post: emilyford33
02-22-2017, 07:18 AM
» Replies: 3
» Views: 4,261
Project Northern Lights
Forum: Show-And-Tell
Last Post: mlapasa
01-25-2017, 12:05 PM
» Replies: 3
» Views: 541
What sources do people us...
Forum: General Discussion
Last Post: stharocks77
01-14-2017, 11:39 AM
» Replies: 3
» Views: 7,525
AllPixels to drive a 6x9x...
Forum: AllPixel Support
Last Post: ghowles
01-12-2017, 12:30 AM
» Replies: 5
» Views: 848
Need help to determine a ...
Forum: BiblioPixel Support
Last Post: vied12
12-31-2016, 01:41 PM
» Replies: 3
» Views: 619
LarsonScanner Problem
Forum: BiblioPixel Support
Last Post: kwalkerk
12-25-2016, 01:00 PM
» Replies: 4
» Views: 510
Individual LED control or...
Forum: General Discussion
Last Post: Adam
12-24-2016, 05:41 PM
» Replies: 5
» Views: 898
Matrix dots made of multi...
Forum: General Discussion
Last Post: jack
12-24-2016, 07:47 AM
» Replies: 8
» Views: 3,204

 
  New tdsp color list Python library.
Posted by: TomSwirly - 05-18-2016, 09:35 PM - Forum: BiblioPixel Development - Replies (1)

A high-performance Cython (C++ for Python) library for color math, aimed at replacing the color math in BiblioPixel - check it out!

Print this item

  run-pixelweb, serial output, not stable for me
Posted by: OSComputing - 05-01-2016, 12:05 AM - Forum: AllPixel Support - No Replies

I wrote Adam, but felt I should post here as well.

Basically I'm having a lot of problems with pixelweb. It works fine with "visualizer" set as the output. But it always hangs after a minute or two when i set output to "serial(allpixel.)

I can it to work, I've been able to test the animations. But it ALWAYS locks up, usually in less than 60 seconds. Then I have to close the command window and start all over. CTRL-C does not exit, I have to close the CMD or end task.

The last run, I got this as the last message before it all seized up:
WARNING - animation - Frame-time of 33ms set, but took 50ms!
DEBUG - animation - Frame: 0ms / Update Max: 5ms
DEBUG - animation - Frame: 0ms / Update Max: 4ms
DEBUG - animation - Frame: 0ms / Update Max: 3ms
DEBUG - animation - Frame: 0ms / Update Max: 3ms
DEBUG - animation - Frame: 0ms / Update Max: 4ms
WARNING - animation - Frame-time of 33ms set, but took 42ms!
DEBUG - animation - Frame: 0ms / Update Max: 4ms
DEBUG - animation - Frame: 0ms / Update Max: 4ms
DEBUG - animation - Frame: 0ms / Update Max: 4ms
ERROR - serial_driver - There was an unknown error communicating with the device.
Exception in thread Thread-21:
Traceback (most recent call last):
 File "c:\python27\lib\threading.py", line 801, in __bootstrap_inner self.run()
 File "c:\python27\lib\site-packages\bibliopixel\led.py", line 39, in run self._driver._update(self._data)
 File "c:\python27\lib\site-packages\bibliopixel\drivers\driver_base.py", line 51, in _update self.update(data)
 File "c:\python27\lib\site-packages\bibliopixel\drivers\serial_driver.py", line 327, in update DriverSerial._comError()
 File "c:\python27\lib\site-packages\bibliopixel\drivers\serial_driver.py", line 165, in _comError raise IOError(error)
IOError: There was an unknown error communicating with the device.

As you can see it was working, then it just hung up. I get other errors at different times as well.

I can run the test scripts from the command line to my device all day long, I'm pretty sure the device works fine on its com port (com4).

EDIT:
Most common debug messages are the following, lasts  about 90 seconds, then locks up.

File "c:\python27\lib\site-packages\serial\serialwin32.py", line 313, in write
raise writeTimeoutError
SerialTimeoutException: Write timeout

-and-

SerialException: WriteFile failed (WindowsError(22, 'The device does not recognize the command.'))

Print this item

  Problem with multiple LED strips
Posted by: cougarkevin - 04-18-2016, 11:12 PM - Forum: BiblioPixel Support - Replies (3)

I finally installed my LED's today, and what worked on my breakfast table does not work on my Christmas tree!

I have encountered a slight problem with the following configuration.
* Two strips of 120 LED's (DotStar APA102's from Adafruit).  
* Each strip is powered by a PowerTap.
* Both PowerTaps are connected to the same 10 amp, 5V power supply (also from Adafruit).  
* Both strips share a common ground with the AllPixel.
* Both clock and data outputs from AllPixel are connected to each strip.

It works for both strips on the breakfast table, works for one strip or the other on the Xmas tree, but does not work for both strips on the Xmas tree!  

The only difference between the breakfast table and the Xmas tree is about 5 feet of shielded, 4 conductor, 24 gauge wire for each strip.  Any thoughts?  I am at a total loss.

While on the topic, it's obvious from looking at the tree that I am going to need a lot more LED's or a lot fewer LEDs / Inch, My RPi3 is already having trouble keeping up with some of the animations on 120 LEDs at 45 - 60 fps.  Any thoughts on how to scale the number of LEDs?  Multiple AllPixels?  Multiple RPis?

Best Wishes,

ks



Attached Files Thumbnail(s)
   
Print this item

  Trouble auto starting PixelWeb on Raspberry Pi 2
Posted by: firebill - 04-16-2016, 12:47 AM - Forum: BiblioPixel Support - Replies (4)

Not sure if this is the right place for this question.

I am using a Raspberry Pi 2 to run an AllPixel. Pixel web runs great when I launch it from the console. The trouble I am having is to have it run automatically in the background anytime the Pi boots up.

I have followed the instructions on the PixelWeb wiki:

add @reboot run-pixelweb > /tmp/pixelweb.log to the crontab

Is there something simple I am missing or is there a different way to do it on the Raspberry Pi?

Thanks for any help.

Print this item

  Data packet size incorrect
Posted by: cougarkevin - 04-05-2016, 07:50 AM - Forum: BiblioPixel Support - Replies (12)

Is anyone else getting this error?

ERROR - serial_driver - 1: Data packet size incorrect.
Exception in thread Thread-57:
Traceback (most recent call last):
 File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
   self.run()
 File "/usr/local/lib/python2.7/dist-packages/bibliopixel/animation.py", line 24, in run
   self._anim._run(**self._args)
 File "/usr/local/lib/python2.7/dist-packages/bibliopixel/animation.py", line 124, in _run
   self._led.update()
 File "/usr/local/lib/python2.7/dist-packages/bibliopixel/led.py", line 136, in update
   d._update(self.buffer[pos:d.bufByteCount + pos])
 File "/usr/local/lib/python2.7/dist-packages/bibliopixel/drivers/driver_base.py", line 51, in _update
   self.update(data)
 File "/usr/local/lib/python2.7/dist-packages/bibliopixel/drivers/serial_driver.py", line 329, in update
   DriverSerial._printError(ord(resp))
 File "/usr/local/lib/python2.7/dist-packages/bibliopixel/drivers/serial_driver.py", line 159, in _printError
   raise BiblioSerialError(msg)
BiblioSerialError: Data packet size incorrect.

Best wishes,

ks

Print this item

  Newbie Help (RPi3, LDP8806)
Posted by: Agilecollab - 03-21-2016, 03:57 PM - Forum: BiblioPixel Support - Replies (6)

Hi All,

I have a project that I'm working on for my wedding this summer. I'm creating 12 independently controlled light fixtures that will light 12 silk lanterns that we purchased on a trip to Asia. I've been waiting on the shipment for the controllers I intend to use for the project but in the mean time i thought it would be a good introduction to get them setup with a RPi3.

I have the strip powered, I have gone through the SPI Setup, but I can't seem to get any response from the LED strip for any of the scripts that I have tried writing... wondering if anyone would have any insight into what the problem might be.

Here is a breakdown of my setup.

RPi3 running Jessie, the led strip is powered by a 5v 1A power supply, I have DI on the strip connected to pin 19 and CI to pin 23, 

$ pip freeze

Code:
BiblioPixel==2.0.9
chardet==2.3.0
colorama==0.3.2
gpiozero==1.1.0
html5lib==0.999
lxkeymap==0.1
mcpi==0.1.1
ndg-httpsclient==0.3.2
numpy==1.8.2
picamera==1.10
pifacecommon==4.2.1
pifacedigitalio==3.1.0
Pillow==2.6.1
pyasn1==0.1.7
pygame==1.9.2a0
pygobject==3.14.0
pyOpenSSL==0.13.1
pyserial==3.0.1
requests==2.4.3
RPi.GPIO==0.6.2
RTIMULib==7.2.1
sense-hat==2.1.0
six==1.8.0
spidev==3.1
urllib3==1.9.1

I do see see the SPI devices within /dev/
$ls /dev/soi*
Code:
/dev/spidev0.0  /dev/spidev0.1


Simple Python Script
Code:
#!/usr/bin/env python

from bibliopixel import *
from bibliopixel.drivers.LPD8806 import *
from bibliopixel.led import *
import bibliopixel.colors as colors


log.setLogLevel(log.DEBUG)

driver = DriverLPD8806(16, use_py_spi=True, c_order=ChannelOrder.RGB, dev="/dev/spidev0.0", SPISpeed=2 )
led = LEDStrip(driver)


print 'one'
led.all_off()
print 'two'
led.fillRGB(100,100,100)
print 'three'
led.update()
print 'four'


Now, when i run this script i don't get any errors, the script runs and returns however after some testing nothing runs after "led.update()" the output from the script looks like this: 

$ sudo ./test.py
Code:
INFO - spi_driver_base - py-spidev speed @ 2.0 MHz
one
two
three


It appears that the script stops execution after the call to update, and does not provide an error as to why the script exits... somewhat weird. Any idea what might be the issue here? Any help would be greatly appreciated. 

Thanks in advance! 

Print this item

  ImageAnim issue LP
Posted by: Oliver - 03-18-2016, 12:20 PM - Forum: BiblioPixel Support - Replies (3)

Hello,
I try do a image animation with several BPM files,
When I run my script in the virtualizer, all is OK but when I run it on my LP8806 16x10 Matrix, all the black pixel become white.
I check c_order and it seems good because all the other animation gives good color with same parameters

driver = DriverLPD8806(numLeds, c_order = ChannelOrder.BRG, SPISpeed = 2)

Any idea
Thanks

Same issue with animated GIF.

Print this item

  Issue with matrix
Posted by: grasib - 02-26-2016, 06:30 PM - Forum: BiblioPixel Support - Replies (2)

Hi there

I'm currently running into an issue with an LED matrix I'm building and was wondering whether anything like this is known or whether there is an issue with my LED strip.
I'm using an LPD8806 Led Strip on a Raspberry PI B+ with Jessie..

Bibliopixel 2.07
spidev 3.1
python 2.7.9

While I tried to dim the matrix gradually to all black [0,0,0] from whatever the colors are i noticed big brightness steps. So I wrote a small test program which gives me the possibility to adjust each color manually.

Code:
from bibliopixel.led import *
from bibliopixel.drivers.LPD8806 import *
import spidev

driver = DriverLPD8806(12*11, c_order = ChannelOrder.BRG, SPISpeed = 2)
led = LEDMatrix(driver, 12, 11)

r = 0
g = 0
b = 0
  
while (1):

    r = int(raw_input("r: "))
    g = int(raw_input("g: "))
    b = int(raw_input("b: "))

    tuple=[r,g,b]
    print tuple

    led.setRGB(5,5,r,g,b)
    led.update()

for red, from [0,0,0] till [27,0,0] the red of the LED's seem to be in an off state.
Then from [28,0,0] till [43,0,0] is the same brightness level
Then from [44,0,0] till [52,0,0] is the same brightness level
and so on in similar ranges all the way to 255. This happens on all the color channels.

Is there a way around this or do I have an issue with my LED-Strip?

Print this item

  Pixel web error
Posted by: Rolie - 02-25-2016, 01:45 PM - Forum: BiblioPixel Support - Replies (2)

Trying to install pixelweb "sudo pip install pixelweb" but get this error. " Could not find a version that satisfies the requirement pixelweb (from version s: 1.0b1, 1.0b2, 1.0b3, 1.0b4, 1.0b6, 1.0b7, 1.0b8)
Cleaning up
No distributions matching the version for pixelweb"
 
Any help would be great 8)
Thanks

Print this item

  Troubleshooting after initial build
Posted by: wp4 - 02-16-2016, 01:59 PM - Forum: AllPixel Support - Replies (2)

Just got around to assembling my AllPixel. Everything looks fine and the green LED lights up when I connect it to my Mac but the computer never sees it. The the ATMega32 gets very hot as well.

Any ideas?

Thanks,

-wp4

Print this item